Writing /var/www/html/www.redcurrant.io/data/meta/documentation/1.8.1/compilation.meta failed
Unable to save metadata file. Hint: disk full; file permissions; safe_mode setting.

How to compile from source

Page for release 1.8.1. See this page for: release 1.8.2, release 1.8.4

First, you'll need to compile gridinit and asn1c, 2 dependencies of Redcurrant that we provide in the project.

Gridinit

Dependencies

Gridinit uses autotools and is coded in C, so you have to install the following tools to compile it: autoconf, automake, make and gcc, bison, flex and libtool.
Compiling Gridinit requires header files for glib >= 2.18, log4c and libevent >= 2.0.

Download the source

git archive --remote=https://github.com/redcurrant/gridinit.git master | tar xvf -

Compilation

In the source directory, run the following commands:

autoreconf -i

./configure
make
make install


asn1c

We are currently using a patched version of asn1c based on release 0.9.21.

Dependencies

asn1c uses autotools and is coded in C, so you have to install the following tools to compile it: autoconf, automake, make and gcc.

Download the source

git archive --remote=https://github.com/redcurrant/asn1c.git master | tar xvf -

Compilation

In the source directory, run the following commands:

./configure
make
make install


Redcurrant

Dependencies

Redcurrant is coded in C and uses cmake to compile, here is the list of what you'll need: gcc, cmake, glib >= 2.28, flex, bison, perl, python >= 2.6, openssl, sqlite >= 3.16, net-snmp, neon, libevent >= 2.0, apr, dbus, dbus-glib, libattr, httpd >= 2.2, zlib, lzo, zookeeper, Perl module Template::Toolkit, asn1c (patched) and gridinit.

Download the source

git archive --remote=https://github.com/redcurrant/redcurrant.git master | tar xvf -

Compilation

In the source directory, run the following commands:

cmake .
cd rules-motor/lib/python; python ./setup.py build
make install

User Tools